I worked with a customer who has a network with a server segment, a workstation segment, and a segment used for mass upgrades using Symantec's Ghost in MultiCast mode.
If multicasting is not turned on in a network, multicast packets will simply flood the whole network
because the switches and routers
have not been told how to deal with the packets, and they are forwarded by default.
For simple networks, Cisco recommends the following basic configuration:
conf t
ip multicast-routing
interface vlan xx
ip pim sparse-dense
end
In this case, I needed to do coordinated multicast routing among segments, and I wanted to keep multicast packets away from a router that
wouldn't be able to handle the load. For this instance, things needed to be fine tuned.
I referred to the following url's for assistance:
This is the basic multicast config I put in place for a 3560 with ADVIPSERVICES:
ip routing
!
ip multicast-routing distributed
interface Loopback0
description for RP/MA
ip address 10.19.1.252 255.255.255.255
ip pim sparse-mode
!
interface Vlan104
ip address 10.10.4.253 255.255.255.0
no ip unreachables
ip pim sparse-mode
standby 104 ip 10.10.4.254
standby 104 priority 110
standby 104 preempt
!
interface Vlan116
ip address 10.10.19.253 255.255.252.0
no ip unreachables
ip pim sparse-mode
standby 116 ip 10.10.19.254
standby 116 priority 110
standby 116 preempt
!
ip pim rp-address 10.19.1.252
ip pim send-rp-announce Loopback0 scope 1
ip pim send-rp-discovery Loopback0 scope 1
!
A few notes:
- A helper address on other segments points to the Ghost server
- for pim multicast interface with higher address is DR
- for hsrp, higher priority interface is DR
- therefore can make local traffic through router and
- . multicast traffic through switch for non-monitored traffic
- . don't mess with any of the standby configs or the vlan addresses